Scania NextGen Highpipes 1.33.x

0
280


rarhigh_pipe_next_gen



rarhigh_pipe_next_gen



rarhigh_pipe_next_gen

Hello the highpipes for next gen are updated to 1.33 they work also on other version the oldest version is 1.30 they work on scania.r_2016 an also scania.s_2016



rarhigh_pipe_next_gen

Credits:



rarhigh_pipe_next_gen

gunther, scs an rjl



rarhigh_pipe_next_gen

LEAVE A REPLY

Please enter your comment!
Please enter your name here

This site uses Akismet to reduce spam. Learn how your comment data is processed.